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Условные обозначения 
В данном руководстве используются следующие условные обозначения: 
» Символ  »  обозначает последовательность вызова пунктов 

вложенных меню или разделов диалоговых окон. Например, 
последовательность File»Page Setup»Options означает, что 
необходимо открыть меню File, выбрать пункт Page Setup и 
затем нажать Options в диалоговом окне. 

♦ Символ ♦ означает, что следующий далее текст относится 
только к определенному продукту, определенной 
операционной системе или определенной версии 
программного обеспечения. 

 

Иконка обозначает дополнительную справочную 
информацию. 

 

Иконка обозначает важную информацию, которую следует 
запомнить  

 

Иконка обозначает предостережение от действий, которые 
могут привести к потере данных или сбоям операционной 
системы. Если таким символом отмечено оборудование, 
следует принять меры предосторожности, описанные в 
руководстве «Безопасность эксплуатации и радиопомехи» 
(Read Me First: Safety and Radio-Frequency Interference) 

Жирный шрифт Жирный шрифт выделяет названия элементов диалоговых 
окон и меню, которые нужно выбрать. 

Курсив Курсивом обозначены ссылки на дополнительную 
информацию. 

Моноширный шрифт Моноширным шрифтом выделяется текст, который 
необходимо ввести с клавиатуры, исходный код, пример 
программы или синтаксиса. Этот шрифт также используется 
для обозначения логических дисков, путей, директорий, имен 
файлов, расширений и функций. 

Устройства NI-DAQmx Имеются ввиду генераторы сигналов NI кроме NI 
5401/5411/5431. 

Традиционные устройства 
NI-DAQ 

Генераторы сигналов NI 5401/5411/5431 

 

Системные требования 
Для работы с генератором сигналов NI при помощи пакета NI-FGEN система должна 
соответствовать минимальным требованиям. Также должна быть установлена указанная 
операционная система. Для обеспечения оптимальной производительности используйте 
систему, удовлетворяющую рекомендуемым требованиям. Если вы планируете создавать 
приложения с использованием генератора сигналов NI, вам понадобится одна из 
перечисленных сред разработки и документация к ней. 

Минимальные системные требования 
• Процессор — Pentium III 600 МГц или эквивалентный 
• Оперативная память — 128 MB 



• Экран с разрешением 800х600 и 256 цветами 
• Windows 2000/XP со всеми критически важными обновлениями и сервисными 

пакетами. 

Рекомендуемые системные требования 
• Процессор — Pentium IV или эквивалентный 
• Оперативная память — 256 MB 
• Экран с разрешением 1024х768 

Среды разработки приложений 
Если вы планируете создавать приложения с использованием генератора сигналов NI, вам 
понадобится одна из перечисленных сред разработки и документация к ней. 

• NI LabVIEW 7.0 или более поздняя версия (для использования Express VI из пакета 
NI-FGEN требуется LabVIEW 7.1 или более поздняя версия) 

• NI LabVIEW Real-Time Module 7.1 или более поздняя версия (кроме модулей NI 
5401/5411/5431) 

• LabWindows™/CVI™ 7.0 или более поздняя версия 
• Measurement Studio 6.0 или более поздняя версия  
• Microsoft Visual C++ (MSVC) 6.0 или более поздняя версия 
• Microsoft Visual Basic 6.0 

Распаковка модуля 
Генераторы сигналов National Instruments поставляются в антистатической упаковке, 
чтобы предотвратить повреждения модуля статическим электричеством. 
Электростатический разряд может вывести из строя некоторые компоненты модуля. 

 ни в коем случае не дотрагивайтесь до открытых контактов модуля. 
Во избежание повреждения модуля, примите следующие меры предосторожности: 

• наденьте антистатический браслет или возьмитесь за заземленный объект 
• перед тем, как извлечь модуль из упаковки прикоснитесь антистатической 

упаковкой к металлической части заземленного корпуса компьютера. 
Извлеките модуль из упаковки и осмотрите его на предмет незакрепленных элементов и 
других механических повреждений. Если модуль кажется поврежденным, обратитесь в 
представительство NI. Не устанавливайте поврежденный модуль в компьютер. 
Если модуль не используется, храните его в антистатической упаковке. 

Комплектация 
Генераторы сигналов NI поставляются в следующей комплектации: 

• модуль генератора сигналов NI 
• Кабель SMB-BNC (только для моделей (NI 5404/5412/5421/5422/5441) 
• Пакет инструментальных драйверов NI-FGEN в DVD-упаковке, содержащей: 

o диски NI-FGEN, содержащие справочную систему NI Signal Generators Help 
o Вводное руководство по использованию генераторов сигналов NI. 

• Диск NI Analog Waveform Editor CD (только для моделей NI 5412/5421/5422/5441) 
• Прочая документация: 

o Технические характеристики генератора сигналов NI 
o Руководство «Безопасность эксплуатации и радиопомехи» (Read Me First: 

Safety and Radio-Frequency Interference) 



o Руководство «Организация воздушного охлаждения» (Maintain Forced-Air 
Cooling Note to Users) 

o Руководство «Модификация модулей PXI» (Retrofitting Your PXI Module 
Note to Users) 

• Диск NI Composite Video Generator CD (только для модели NI 5431) 

Защитная накладка 
Генератор сигналов NI может поставляться с защищающей от радиопомех накладкой и 
документаций по ее использованию. Информацию об установке защитной накладки 
можно найти в разделе «Установка модулей PXI». 

Дополнительные принадлежности 
Кроме входящих в комплект компонентов, вам понадобятся следующие принадлежности: 

• отвертка с плоским шлицом на 1/8 дюйма; 
• совместимые с вашим модулем соединительные кабели.  
• Для модулей PXI — шасси PXI, комбинированное шасси PXI/SCXI, или шасси 

PXI/CompactPCI вместе с контроллером или мостом MXI, а также документация к 
шасси; 

• Для модулей PCI — компьютер (desktop) и документация к нему; 

Если вы используете синхронизацию NI-TClk, устройства должны быть 
соединены кабелем RTSI (только для модулей PCI DAQmx, кроме NI 5404) 

Установка программного обеспечения 
На диске NI-FGEN CD, входящем в комплект поставки, содержатся драйвера для всех 
генераторов сигналов NI. На диске также содержится пакет FGEN Soft Front Panel (SFP). 
FGEN SFP — простой и эффективный интерактивный инструмент, позволяющий сразу 
приступить к работе с генераторами сигналов NI. 
Чтобы установить NI-FGEN, выполните следующие действия: 

1. (не обязательно) Установите среду разработки, например NI LabVIEW или 
LabWindows/CVI, если вы хотите создавать приложения с использованием 
генератора сигналов NI. 

2. Вставьте диск NI-FGEN CD в привод и следуйте указаниям мастера установки. 

 Если окно мастера установки не появилось, запустите файл setup.exe, 
находящийся на диске. 

3. Когда установка закончится, появится диалоговое окно выбора следующего 
действия (перезарузка, выключение или выход). Выберите Restart (перезагрузка). 

4. Если используется система на основе LabVIEW Real-Time Module, загрузите NI-
FGEN на целевое устройство при помощи Measurement & Automation Explorer 
(MAX). Воспользуйтесь справочной системой Measurement & Automation Explorer 
Remote Systems Help (выберите Help»Help Topics»Remote Systems в главном меню 
MAX) 

5.  (только для NI 5431) Вставьте диск NI Composite Video Generator CD в привод. 
Нажмите Install в открывшемся окне установки и следуйте дальнейшим 
инструкциям. 



Установка оборудования 

 Перед установкой компьютер или шасси PXI должны быть отключены от сети 
питания. 
Держите модуль за края или металлическую заглушку, чтобы избежать загрязнения или 
повреждения модуля статическим разрядом в процессе установке. Дополнительная 
информация приведена в руководстве «Безопасность эксплуатации и радиопомехи» 
(ReadMe First: Safety and Radio-Frequency Interference). Способы обеспечения 
оптимального воздушного охлаждения описаны в руководстве «Организация воздушного 
охлаждения» (Maintain Forced-Air Cooling Read Me First), входящем в комплект поставки. 

Перед установкой модуля инсталлируйте пакет инструментальных драйверов NI-
FGEN. 

Охлаждение модулей PCI и PXI 

 При установке генератора сигналов NI-DAQmx (кроме NI 5404) следуйте 
руководству «Организация воздушного охлаждения» (Maintain Forced-Air Cooling Read Me 
First), входящему в комплект поставки, чтобы обеспечить эффективное охлаждение. 
Если в процессе работы температура устройства превысит максимально допустимую, 
устройство автоматически выключится, затем MAX или NI-FGEN выдаст 
соответствующее сообщение об ошибке. Чтобы включить устройство после 
автоматического отключения необходимо выполнить полный сброс (hard reset) одним из 
следующих способов: 

• Выключите компьютер или шасси. После того, как устройство охладится, вновь 
включите компьютер или шасси и при необходимости перезагрузите контроллер. 

• Запустите niFgen Reset Device VI (niFgen_ResetDevice) или выполните сброс 
устройства (device reset) в MAX. Дополнительную информацию о сбросе 
устройства при помощи MAX можно найти в справочной системе (выберите 
Help»Help Topics»NI-DAQmx»Measurement & Automation Explorer Help for NI-
DAQmx в главном меню MAX). 

Способы обеспечения оптимального воздушного охлаждения описаны в руководстве 
«Организация воздушного охлаждения» (Maintain Forced-Air Cooling Read Me First). 
Сообщение об ошибке перегрева будет выдаваться, пока температура не опустится до 
приемлемого уровня и пока не будет выполнен сброс устройства. 

Установка модуля PXI 
Чтобы установить модуль на шасси PXI, комбинированное шасси PXI/SCXI, или шасси 
PXI/CompactPCI, выполните следующие действия: 

1. Выключите и отсоедините шасси PXI от сети питания. 
2. (Дополнительно) Установите защитную накладку, если необходима защита от 

радиопомех. Дополнительную информацию об установки накладки можно найти в 
руководстве «Модификация модулей PXI» (Retrofitting Your PXI Module Note to 
Users) 

3. Установите модуль в свободный слот PXI (защелка должна оказаться в верхнем 
положении) и закрепите его винтами (рис. 1) 



4. Убедитесь, что вентиляторы шасси PXI не повреждены и не содержат загрязнений, 
препятствующий воздушному потоку. Дополнительную информацию можно найти 
в разделе «Охлаждение модулей PCI и PXI». 

5. Подсоедините шасси к сети питания и включите его. 

 
1  шасси PXI 
2  модуль NI PXI 

3  крепежный винт 
4  защелка 

Рис. 1.  Установка модуля PXI 
  

Извлечение модуля PXI 
Перед извлечением модуля PXI наденьте антистатический браслет или возьмитесь за 
заземленный объект. Во избежание повреждения модуля электростатическим разрядом не 
дотрагивайтесь до открытых контактов модуля. Если модуль не используется, храните его 
в антистатической упаковке. 

 Во время работы металлические поверхности модуля PXI могут нагреваться. 
Будьте осторожны при извлечении или перемещении модуля в другой слот. Держите 
модуль только за края или металлическую заглушку. 

Установка модуля PCI 
Чтобы установить модуль, выполните следующие действия: 

1. Выключите и отсоедините компьютер от сети питания. 
2. Снимите крышку корпуса компьютера 
3. Установите модуль в свободный слот PCI  (см. рис. 2) 



 Оставьте соседние слоты пустыми чтобы обеспечить лучшее охлаждение 
модуля. 

4. Закрепите модуль прилагающимся винтом. 

Следует хорошо закрепить модуль винтом чтобы обеспечить как 
механическую устойчивость, так и качественное заземление, которое необходимо 
для снижения уровня шума. Неправильно закрепленный модуль может не 
соответствовать указанным техническим характеристикам. 
Корпуса некоторых производителей имеют пластиковые крепления на слотах PCI. 
Использование подобных креплений недопустимо, их необходимо заменить. 
Используйте винт, входящий в комплект поставки модуля. Вышесказанное не 
относится к традиционным устройствам NI-DAQ. 

5. Убедитесь, что вентиляторы корпуса не повреждены и не содержат загрязнений, 
препятствующий воздушному потоку. Дополнительную информацию можно найти 
в разделе «Охлаждение модулей PCI и PXI» 

6. Закройте корпус компьютера крышкой. 
7. Подсоедините компьютер к сети питания. 

 
1  модуль NI PCI 
2  слот PCI 

3  корпус компьютера 
 

Рис. 2.  Установка модуля PCI 



 

Первое включение компьютера или шасси PXI 
Windows обнаружит новое устройство при первой загрузке компьютера после установки 
модуля. На некоторых компьютерах может появиться окно «Мастер установки 
оборудования». По умолчанию выбран пункт «Автоматически установить программное 
обеспечение (рекомендуется)». Кликните Далее или Да чтобы установить программное 
обеспечение для каждого устройства. 
♦  (для всех устройств DAQmx PCI) Убедитесь, что в BIOS компьютера включена опция 
spread-spectrum clocking. Дополнительную информацию о данной опции можно найти в 
документации к материнской плате компьютера. Отключение опции spread-spectrum 
clocking может привести к ухудшению точности генератора сигналов. 

Конфигурирование и тестирование устройства в MAX. 
Выполните следующие действия: 

1. Запустите Measurement & Automation Explorer (MAX), два раза кликнув по иконке 
MAX на рабочем столе. 

 
2. Откройте ветку Devices and Interfaces, затем ветку NI-DAQmx Devices. 

 Если используется удаленный контроллер реального времени, откройте 
ветку Remote Systems, найдите и откройте ветку с именем нужного контроллера, 
затем откройте ветку Devices and Interfaces. 

 



 
1. Все генераторы сигналов кроме NI 5401/5411/5431 представлены в списке NI-

DAQmx Devices. Генераторы  NI 5401/5411/5431 представлены в списке 
Traditional NI-DAQ (Legacy) Devices. 

2. В списке Remote Systems»Devices and Interfaces представлены только устройства 
NI-DAQmx. 

 
В случае модулей NI 5401/5411/5431, откройте ветку Traditional NI-DAQ (Legacy) 
Devices. 

3. Убедитесь, что нужный модуль присутствует в списке Devices and Interfaces. Если 
модуль отсутствует в списке, нажмите <F5> чтобы обновить его. Если после этого 
модуль не появился, следуйте рекомендациям, приведенным на странице 
ni.com/support/install. 

Если для управления шиной PXI используется интерфейс MXI, и 
возникают проблемы с инициализацией или скоростью работы модуля, обратитесь 
к документации интерфейса MXI и убедитесь, что он правильно настроен. 
Возможно, требуется программная оптимизация. В случае MXI-3, выберите 
Пуск»Программы»National Instruments MXI-3»MXI-3 Optimization. В случае 
MXI-4 оптимизация выполняется автоматически. 

4. Запустите самотестирование устройств чтобы поверить правильность установки 
♦  Для устройств NI-DAQmx — кликните правой кнопкой мыши по названию 
устройства в списке и выберите Self-Test 
♦  Для традиционных устройств IN-DAQ — кликните правой кнопкой по названию 
устройства в списке и выберите Properties, затем кликните Test Resources. 



 
Появится диалоговое окно, сообщающее о результате тестирования. Если модуль 
не прошел тестирование, следуйте рекомендациям, приведенным на странице 
ni.com/support/install. 

5. Сконфигурируйте устройство: 
a. Кликните правой кнопкой по генератору сигналов в списке и выберите 

Properties. 
b. Выберите вкладку с необходимыми настройками. Опции во вкладках 

зависят от конкретной модели модуля. 
c. Запишите номер и имя устройства. Они понадобятся при создании 

приложений с использованием устройств. 
♦  Для устройств NI-DAQmx — Имя устройства, добавленное к названию 
модели, отображается в списке. Например, в списке устройство 
отображается как NI PXI-5421: "Dev1", здесь "Dev1" — имя 
устройства. В процессе создания приложений, имя ресурса соответствует 
имени устройства, назначенному в MAX. Вы можете переименовать 
устройство DAQmx, кликнув правой кнопкой мыши по названию устройства 
в списке и выбрав Rename. 
♦  Для традиционных устройств IN-DAQ — Выделите устройство в списке 
чтобы отобразить его свойства в правой части окна. Номер устройства 
отображается в столбце Value. В процессе создания приложений, имя 
ресурса записывается как DAQ::n, где n — номер, назначенный устройству 
MAX. 

 Чтобы не изменять код имеющихся использующих традиционные 
устройства NI-DAQ приложений, смените имя имеющегося устройства NI-
DAQmx на номер традиционного устройства NI-DAQ, заданного в 
приложении. 

d. Кликните OK в окне конфигурирования устройства чтобы зарыть его. 

Настройка синхронизации устройств NI-DAQmx в MAX. 

Данный раздел относится к любому типу синхронизации NI-DAQmx устройств, 
включая синхронизацию NI-TClk. Дополнительную информацию о синхронизации NI-
TClk можно найти в справочной системе NI Signal Generators Help (Programming»NI-
TClk Synchronization Help). 



Если планируется использование триггеров или опорных частоты для синхронизации 
устройств NI-DAQmx, необходимо настроить определенные компоненты в MAX. 
♦  В случае модулей PXI, необходимо определить контроллер PXI: 

1. Запустите MAX. В списке Devices and Interfaces кликните правой кнопкой мыши по 
PXI System и выберите Identify As, затем выберите контроллер из списка. 
Например, выберите External PC, если используется контроллер MXI-3 или MXI-4. 

2. Откройте ветку PXI System и определите используемое шасси. 
♦  В случае модулей PCI, необходимо сконфигурировать систему для использования 
кабеля RTSI: 

1. Соедините модули PCI кабелем RTSI, тем самым обеспечьте физическое 
соединение линий триггеров и опорных частот. 

2. Запустите MAX. В списке Devices and Interfaces кликните правой кнопкой мыши по 
DAQmx Devices.  

3. Выберите Create New NI-DAQmx Device»RTSI Cable. 
4. Чтобы добавить устройство, соединенное кабелем RTSI, кликните правой кнопкой 

мыши по названию кабеля RTSI в списке и выберите Add Device to RTSI Cable. 

Интерактивная генерация сигнала заданной формы 
Для интерактивной генерации используется приложение NI FGEN SPF. 
♦  (только для модуля NI-5431) При помощи мастера NI Video Generator Wizard вы можете 
генерировать видеосигнал.  

Генерация сигналов стандартных форм 
♦  (только для модулей NI 5401/5404/5411/5431) Чтобы сгенерировать сигнал стандартной 
формы при помощи вашего модуля, выполните следующие действия: 

1. Запустите приложение FGEN SFP, выбрав Пуск»Программы»National 
Instruments»NI-FGEN»FGEN Soft Front Panel. 

2. Убедитесь, что название нужного модуля отображается в окне FGEN SPF (рис. 3) 
 



Рис. 3.  Окно приложения FGEN SFP, выбран модуль NI PXI-5411 
 

  Если название нужного модуля не отображается или в системе 
установлено несколько генераторов сигналов NI, выберите Edit»Device 
Configuration. В диалоговом окне Device Configuration кликните на стрелку 
выпадающего списка и выберите нужный модуль из списка (рис. 4). Нажмите OK 
чтобы закрыть окно Device Configuration. 

 



 
Рис. 4.  Диалоговое окно Device Configuration 

 
3. Убедитесь, что активен переключатель режима генерации сигнала стандартной 

формы . 
4. Установите частоту, амплитуду, сдвиг и тип генерируемого сигнала. 

5. Нажмите кнопку Run  чтобы запустить генерацию. 
Параметры по умолчанию для модулей NI 5401/5404/5411/5431 соответствуют 
непрерывному синусоидальному сигналу с частотой 1 МГц, амплитудой 1 В, 
рассчитанной на нагрузку 50 Ом, и нулевым фазовым сдвигом. Вы можете изменять эти 
параметры, чтобы генерировать сигнал нужной формы. Дополнительную информация о 
FGEN SPF можно получить в справочной системе (выберите Help»FGEN SFP Help или 
Help»Show Context Help). Чтобы получить информацию об определенной модели 
устройства, выберите Help»Hardware-Specific Help. 

Генерация сигналов произвольной формы 
Чтобы сгенерировать сигнал произвольной формы при помощи вашего модуля, 
выполните следующие действия: 

 Модели NI 5401/5402/5404/5406 не поддерживают генерацию сигналов 
произвольной формы. 

1. Запустите FGEN SFP, выбрав Пуск»Программы»National Instruments»NI-
FGEN»FGEN Soft Front Panel. 

2. Убедитесь, что название нужного модуля отображается в окне FGEN SPF (рис. 3) 
 

  Если название нужного модуля не отображается или в системе 
установлено несколько генераторов сигналов NI, выберите Edit»Device 
Configuration. В диалоговом окне Device Configuration кликните на стрелку 



выпадающего списка и выберите нужный модуль из списка (рис. 4). Нажмите OK 
чтобы закрыть окно Device Configuration. 

3. Убедитесь, что активен переключатель режима генерации сигнала произвольной 

формы . 
4. Кликните по списку Current Waveform Pattern (текущий образ сигнала) и выберите 

Load Waveform from disk (загрузить с диска)  чтобы загрузить цифровой образ 
сигнала в собственную память модуля. Откроется диалог загрузки файла и окно 
Select File (выбор файла). В окне Select File отображены имеющиеся примеры 
образов сигналов. 

  Можно загрузить образ сигнала, выбрав File»Load New Waveform. Путь 
по умолчанию к примерам образов сигналов: 
\\Program Files\IVI\Drivers\niFgen\Waveform\Examples. 

5. Выберите файл arbMode-sine.lvm и нажмите OK. Появится окно 
предварительного просмотра формы сигнала, которое можно закрыть или свернуть. 

6. В диалоговом окне File Load (загрузка файла) выберите один из следующих 
наборов параметров из выпадающего списка Waveform: 
♦  (только для NI-PXI-5411/5431) sine, 16MHz@40MS/s 
♦  (только для NI-PXI-5421) sine, 40MHz@100MS/s 

7. Нажмите OK в диалоговом окне File Load. 

8. Нажмите кнопку Run  чтобы запустить генерацию. Выберите Edit»Device 
Configuration и измените параметры фильтра  чтобы добиться оптимальной 
формы синусоидального сигнала. 

Параметры по умолчанию для модулей NI 5411/5421/5431 соответствуют непрерывному 
синусоидальному сигналу с частотой 1 МГц, амплитудой 1 В, рассчитанной на нагрузку 
50 Ом, и нулевым фазовым сдвигом. Вы можете изменять эти параметры, чтобы 
генерировать сигнал нужной формы. Дополнительную информация о FGEN SPF можно 
получить в справочной системе (выберите Help»FGEN SFP Help или Help»Show Context 
Help). Чтобы получить информацию об определенной модели устройства, выберите 
Help»Hardware-Specific Help. 

Генерация видеосигнала при помощи модуля NI 5431 
Чтобы интерактивно сгенерировать видеосигнал с помощью мастера NI Video Generator 
Wizard выполните следующие действия: 

1. Запустите мастер NI Video Generator Wizard (рис. 5), выбрав 
Пуск»Программы»National Instruments Composite Video Generator»Video 
Generator Wizard. 



 
Рис. 5.  Диалоговое окно мастера NI Video Generator Wizard 

Для запуска мастера NI Video Generator Wizard необходим установленный 
LabVIEW Run-Time Engine 5.1.1. Его можно скачать на странице 
ni.com/softlib.nsf  

2. Чтобы сгенерировать сигнал на основе растрового изображения и установок по 
умолчанию выполните следующие действия (рис. 5): 

a. Убедитесь, что Device ID (номер устройства) установлен верно (в 
соответствии с ранее выбранными в MAX параметрами). 

b. Выберите Load BMP file and compute video data (Загрузить BMP файл и 
рассчитать видеоданные). 

c. Кликните Browse. 
d. Двойным щелчком мыши откройте одну из следующих директорий: 

• Если используется стандарт NTSC, откройте директорию 640x480 или 
1044x480 

• Если используется стандарт PAL, откройте директорию 768x576 или 
1040x576 

  Дополнительную информацию о форматах видеоданных можно 
найти в справочной системе NI Signal Generators Help. 

e. Двойным щелчком мыши отройте любой .bmp файл. Путь к этому файлу 
отобразится в строке BMP Input File Path control box (путь к входному 
BMP файлу). 

f. Выберите Use factory settings (использовать установки по умолчанию). Эта 
опция означает, что видеосигнал будет генерироваться с параметрами по 
умолчанию. 



g. Выберите нужный формат видеосигнала: M-NTSC, Standard-PAL, или 
SECAM. 

h. Выберите Download video data file (загрузить файл видеоданных).При этом 
видеоданные в цифровом виде будут загружены в память модуля NI 5431. 

 Установите галочку Display BMP чтобы отобразить файл .bmp на 
экране компьютера. 

i. Кликните Finish (закончить). Откроется диалоговое окно Processing 
(обработка) в котором будет отображаться состояние процесса обработки 
видеоданных. 

На основе выбранного файла .bmp мастер NI Video Generator Wizard создает 
видеоданные в формате NTSC, PAL, или SECAM, загружает их в память модуля NI 5431 и 
автоматически запускает генерацию сигнала на его выходе VIDEO OUT. 

Программная генерация сигнала заданной формы 
Для создания программ с использованием функций генерации сигналов заданной формы 
применяется пакет NI-FGEN Interchangeable Virtual Instrument (IVI). Вы также можете 
запускать примеры NI-FGEN, демонстрирующие функциональность генераторов сигналов 
NI. 
Дополнительную информацию о работе с NI-FGEN можно найти в справочной системе NI 
Signal Generators Help (Пуск»Программы»National Instruments»NI-
FGEN»Documentation). 

Примеры NI-FGEN 
Примеры Ni-FGEN демонстрируют функциональность генераторов сигналов NI, которая 
может быть интегрирована в ваше приложение. Данные примеры могут служить 
интерактивными инструментами, шаблонами программирования и составными 
компонентами вашего приложения. 
Чтобы найти пример, которые можно использовать в качестве основы первого 
приложения, программисты LabVIEW и LabWindows/CVI могут использовать NI Example 
Finder. В LabVIEW или LabWindows/CVI выберите Help»Find Examples чтобы запустить 
NI Example Finder. Примеры применения Ni-FGEN в С можно найти в меню 
Пуск»Программы»National Instruments»NI-FGEN»Examples»c. 

Инструментальный драйвер NI-FGEN 
Программный интерфейс NI-FGEN представляет собой набор методов и свойств, 
позволяющий полностью реализовать функциональные возможности устройства, в том 
числе конфигурирование, управление и другие специфические функции. 
Информацию о программировании с использованием NI-FGEN можно найти в справочной 
системе NI Signal Generators Help. В справочной системе содержится информация об 
оборудовании, принципах программирования, подробная справочные сведения о 
функциях и виртуальных приборах NI-FGEN, данные о конкретных моделях генераторов. 

NI Composite Video Generator (только для NI 5431) 
Для создания приложений с использованием функций генерации видеосигналов в 
LabVIEW применяется NI Composite Video Generator. Дополнительную информацию о 
функциях генерации видеосигналов в программе можно найти в справочной системе NI 
5431 Composite Video Generator Help. Чтобы открыть справочную систему, выберите 
Help»NI5431 в главном меню виртуального прибора LabVIEW. 



Создание и редактирование образов сигналов 
Для создания и редактирования образов аналоговых сигналов используется приложение 
NI Analog Waveform Editor. Чтобы открыть образ сигнала для просмотра или 
редактирования, необходимо импортировать файл данных, сохраненный в бинарном или 
ASCII формате. После этого образ сигнала доступен для просмотра и редактирования. Вы 
также можете создать новый образ, выбрав в качестве основы один из более чем 20 
готовых образов или введя математическое выражение. 

 
Рис. 6.  Окно NI Analog Waveform Editor 

Для запуска мастера NI Video Generator Wizard необходим установленный 
LabVIEW Run-Time Engine 5.1.1. Его можно скачать на странице 
NI Analog Waveform Editor можно активировать используя серийный номер, 
поставляемый с определенным оборудованием. NI Analog Waveform Editor можно также 
приобрести на сайте ni.com. 

Приложение A: соединительные панели 
В этом разделе приведены схемы соединительных панелей и описания разъемов для 
подключения линий сигналов к генераторам NI. 



NI PXI/PCI-5401 
NI PXI-5401 — генератор сигналов с частотой дискретизации 16 МГц для платформы PXI. 
Модуль NI PXI-5401 имеет четыре разъема — два BNC и два SMB, как показано на рис. 7. 
Описание линий сигналов приведено в табл. 1. 
NI PXI-5401 — генератор сигналов с частотой дискретизации 16 МГц для шины PCI. 
Модуль NI PCI-5401 имеет четыре разъема — три SMB и один 50-пиновый цифровой 
разъем, как показано на рис. 7. Описание линий сигналов приведено в табл. 2. 
 

 

 
Рис. 7.  Соединительная панель модулей NI PXI/PCI-5401 



 
Табл. 1  Разъемы модуля NI PXI-5401 

Разъем Тип Функция 
   

ARB OUT Выход Выход для генерируемого сигнала. 
SYNC OUT Выход TTL-сигнал, синхронный с синусоидальным сигналом на 

выходе ARB OUT. 
EXT TRIG Вход Вход для TTL-сигнала, который можно использовать для 

запуска или переключения режима генерации. 
PLL REF Вход Вход для опорного внешнего сигнала, позволяющий 

привязать внутреннюю частоту NI PXI-5401 к внешнему 
источнику. 

 
Табл. 2.  Разъемы модуля NI PCI-5401 

Разъем Тип Функция 
   

ARB Выход Выход для генерируемого сигнала. 
SYNC Выход TTL-сигнал, синхронный с синусоидальным сигналом на 

выходе ARB. 
PLL IN Вход Вход для опорного внешнего сигнала, позволяющий 

привязать внутреннюю частоту NI PXI-5401 к внешнему 
источнику. 

PATTERN OUT Вход Вход для внешних триггерных сигналов. Дополнительную 
информацию о разъеме и сигналах можно найти в 
справочной системе NI Signal Generators Help   



NI PXI/PCI-5402/5406 
NI 5402 — 14-разрядный генератор сигналов с полосой пропускания 20 МГц. NI 5406 — 
16-разрядный генератор сигналов с полосой пропускания 40 МГц. 
Эти модули имеют шесть разъемов BNC, как показано на рис. 8. Описание линий 
сигналов приведено в табл. 3. 

 

 
Рис. 8.  Соединительная панель модулей NI PXI/PCI-5402/5406 



 
Табл. 3  Разъемы модулей PXI/PCI-5402/5406 

Разъем Тип Функция 
   

CH 0 Выход Выход для генерируемого сигнала. 
REF IN Вход Вход для опорного внешнего сигнала, позволяющий 

привязать внутреннюю частоту к внешнему источнику.  
SYNC OUT/ 
PFI 0 

Вход/выход Либо вход для сигнала с внешнего источника, который 
можно использовать для запуска или переключения 
режимов генерации, либо выход, дублирующий одну из 
линий опорной частоты, линий событий или триггерных 
линий. Дополнительную информацию о разъеме и 
сигналах можно найти в справочной системе NI Signal 
Generators Help. 

PFI 1 Вход/выход Либо вход для сигнала с внешнего источника, который 
можно использовать для запуска или переключения 
режимов генерации, либо выход, дублирующий одну из 
линий опорной частоты, линий событий или триггерных 
линий. Дополнительную информацию о разъеме и 
сигналах можно найти в справочной системе NI Signal 
Generators Help. 



NI PXI-5404 
NI PXI-5404 — генератор частоты до 100 МГц для платформы PXI. 
Модуль NI PXI-5404 имеет пять разъемов SMB, как показано на рис. 9. Описание линий 
сигналов приведено в табл. 4. 

 

 
Рис. 9.  Соединительная панель модуля NI PXI-5404 



 
Табл. 4  Разъемы модуля NI PXI-5404 

Разъем Тип Функция 
   

SINE Выход Выход для синусоидального сигнала заданной частоты 
CLOCK Выход TTL-сигнал, синхронный с синусоидальным сигналом на 

выходе SINE. 
PFI 0 Вход/выход Либо вход для TTL-сигнала, который можно использовать 

для запуска или переключения режимов генерации, либо 
выход для сигнала синхронизации/запуска. 

REF OUT Выход Дублирует сигналы линий синхронизации PXI либо 
пониженную множителем внутреннюю частоту модуля NI-
PXI-5404. 

REF IN Вход Вход для опорного внешнего сигнала, позволяющий 
привязать внутреннюю частоту NI PXI-5404 к внешнему 
источнику. 



NI PXI-5411/5431 
NI PXI-5411 — генератор сигналов произвольной формы с частотой 40 МГц для 
платформы PXI. NI PXI-5431 — генератор видеосигнала для платформы PXI. 
Модули NI PXI-5411/5431 имеют шесть разъемов — два BNC, три SMB и один 50-
пиновый цифровой разъем, как показано на рис. 10. Описание линий сигналов приведено 
в табл. 5. 

 

 
Рис. 10.  Соединительные панели модулей PXI-5411/5431 



 
Табл. 5  Разъемы модулей PXI-5411/5431 

Разъем Тип Функция 
   

ARB/  
VIDEO OUT 

Выход Выход для генерируемого сигнала. 

SYNC OUT Выход TTL-сигнал, синхронный с синусоидальным сигналом 
на выходе ARB/VIDEO OUT. 

EXT TRIG Вход Вход для TTL-сигнала, который можно использовать 
для запуска или переключения режима генерации. 

MARKER OUT Выход TTL-сигнал, который может быть сопоставлен любой 
точке генерируемого сигнала. Данный выход можно 
использовать для синхронизации/запуска внешних 
устройств. 

PLL REF Вход Вход для опорного внешнего сигнала, позволяющий 
привязать внутреннюю частоту PXI-5411/5431 к 
внешнему источнику. К этому входу также можно 
подключить источник внешней опорной частоты. 

DIGITAL 
PATTERN/ 
VIDEO 
DIGITAL 
PATTERN 

Вход/выход Дублирует 16-разрядный триггерный цифровой выход, 
выход опорной частоты, выход MARKER OUT, вход 
EXT TRIG, и выход питания +5 В. Дополнительную 
информацию о разъеме и сигналах можно найти в 
справочной системе NI Signal Generators Help 



NI PCI-5411/5431 
NI PCI-5411 — генератор сигналов произвольной формы с частотой 40 МГц для шины 
PCI. NI PXI-5431 — генератор видеосигнала для шины PCI. 
Модули PCI-5411/5431 имеют четыре разъема — три SMB и один 50-пиновый цифровой 
разъем, как показано на рис. 11. Описание линий сигналов приведено в табл. 6. 

 
 

 
Рис. 11.  Соединительные панели модулей PCI-5411/5431 

 
Табл. 6  Разъемы модулей PCI-5411/5431 

Разъем Тип Функция 
   

ARB Выход Выход для генерируемого сигнала. 
SYNC Выход TTL-сигнал, синхронный с синусоидальным сигналом 

на выходе ARB. 
EXT TRIG Вход Вход для TTL-сигнала, который можно использовать 

для запуска или переключения режима генерации. 
PLL IN Вход Вход для опорного внешнего сигнала, позволяющий 

привязать внутреннюю частоту PCI-5411/5431 к 
внешнему источнику. 

PATTERN OUT 
 

Вход/выход Дублирует 16-разрядный триггерный цифровой выход, 
выход опорной частоты, выход MARKER OUT, вход 
EXT TRIG, и выход питания +5 В. Дополнительную 
информацию о разъеме и сигналах можно найти в 
справочной системе NI Signal Generators Help 



NI PXI/PCI-5412/5421/5441 
NI 5412 — 14-разрядный генератор сигналов произвольной формы до 20 МГц с частотой 
дискретизации 100 МГц. 
NI 5421 — 16-разрядный генератор сигналов произвольной формы до 43 МГц с частотой 
дискретизации 100 МГц. 
NI 5422 — 16-разрядный генератор сигналов произвольной формы до 80 МГц с частотой 
дискретизации 200 МГц. 
NI 5441 — 16-разрядный генератор сигналов произвольной формы до 43 МГц с частотой 
дискретизации 100 МГц с функцией аппаратной обработки сигнала (OSP) 
Данные модули имеют до пяти разъемов — четыре SMB и один 68-пиновый разъем-вилку 
VHDCI, как показано на рис. 12. Описание линий сигналов приведено в табл. 7. 

 
Рис. 12.  Соединительная панель модулей NI PXI/PCI-5412/5421/5441 

 



Табл. 7  Разъемы модулей NI PXI/PCI-5412/5421/5441 
Разъем Тип Функция 

   

CH 0 Выход Выход для генерируемого сигнала. 
CLK IN Вход Вход для опорного внешнего сигнала, позволяющий 

привязать внутреннюю частоту к внешнему источнику. 
К этому входу также можно подключить источник 
внешней опорной частоты. 

PFI 0 Вход/выход Либо вход для сигнала с внешнего источника, который 
можно использовать для запуска или переключения 
режимов генерации, либо выход, дублирующий одну из 
линий опорной частоты, линий событий или триггерных 
линий. Дополнительную информацию о разъеме и 
сигналах можно найти в справочной системе NI Signal 
Generators Help. 

PFI 1 Вход/выход Либо вход для сигнала с внешнего источника, который 
можно использовать для запуска или переключения 
режимов генерации, либо выход, дублирующий одну из 
линий опорной частоты, линий событий или триггерных 
линий. Дополнительную информацию о разъеме и 
сигналах можно найти в справочной системе NI Signal 
Generators Help. 

Digital Data & 
Control (DDC) 

Вход/выход Дублирует 16-разрядный триггерный цифровой выход, 
выход опорной частоты, выход MARKER OUT, вход 
EXT TRIG, и выход питания +5 В. Дополнительную 
информацию о разъеме и сигналах можно найти в 
справочной системе NI Signal Generators Help 



Техническая поддержка 
При возникновении проблем с установкой, настройкой или эксплуатацией оборудования, 
в первую очередь воспользуйтесь Web-поддержкой National Instruments. На сайте 
технической поддержки NI приведены ответы на часто задаваемые вопросы, базы знаний, 
мастера устранения неисправностей для конкретного оборудования, документация, 
драйверы, обновления программного обеспечения и другие ресурсы. Все ресурсы 
доступны в разделе Technical Support на сайте ni.com. 
Заявление о соответствии производителя подтверждает соответствие продукта стандартам 
Евросоюза. Данное оборудование соответствует стандартам электромагнитной 
совместимости (EMC). Заявление о соответствии для вашего оборудования можно 
получить на странице ni.com/hardref.nsf. Если ваше оборудование поддерживает 
калибровку, вы можете получить калибровочный сертификат на странице 
ni.com/calibration. 
 
Если вы искали помощи на ni.com и не нашли ответа, обратитесь  
за бесплатной технической поддержкой в офис National Instruments: 
 
National Instruments Россия, СНГ, Балтия 
119361 г. Москва, ул. Озерная, д.42 офис 1101  
Телефон в Москве: + 7(495) 783-68-51  
Телефон в Санкт-Петербурге: + 7 (812) 951-44-18 
Телефон в Киеве: + 38 (068) 394-21-22 
Электронная почта: support.russia@ni.com 
 
 



Последовательность вызовов ВП 

 

Необходимая последовательность вызовов 
 
Необязательный шаг 
 
Возможное ответвление в последовательности вызовов. 


